Search Function for My Books Not Working

DiscussãoFrequently Asked Questions

Entre no LibraryThing para poder publicar.

Search Function for My Books Not Working

Ago 3, 2010, 2:56 pm

It's not bringing up books I know are in the collection--I've searched by the author's name that is also the title and by isbn which I copied and pasted out of the record itself. I tried changing the search parameters to all fields and title/author fields. I've also searched generic terms like "american" that i know are in multiple records--no results. I tried logging out and back in and it's still doing it.

It will, however, bring up another record by the same author--the difference being that the record was created today.

Editado: Ago 3, 2010, 3:12 pm

you posted your problem in bug collectors which is where problems should be posted.

you don't need to post it in multiple locations.

TPTB will see it & will reply... or someone will.... but you may have to wait.

especially if you don't see any of TPTB are posting, then they may be busy with RL stuff.

Edited to add, please forgive my tone... I shouldn't post when I have a bad headache.

Ago 16, 2010, 12:55 am

I am hoping someone will see my post too. My search window on my home page screen increasingly stops working altogether (or at least past the five minute point of waiting). I have have reindexed my books, which took a long time (I have a big library). Then the search window worked just fine--for the next three books and then stopped working again. This is NOT my first time noticing the unresponsive search window. In the past I just assumed that it was a busy time. This problem now happens somewhat regularly--I can't count on working in LibraryThing for more than 30 minutes without the search function discontinuing. Other elements of LibraryThing work just fine. If I see a title in the ten books listed on my home page, I can click on the title and bring it up. If I search for the same title--nothing.

Maio 13, 10:36 pm

I am having difficulty finding books in my library. I'll do a your books "search your library" and get no hits. But, I know the book is there. Not all books, but many books do not come up for a search. In order to find them, I have to click on "your books" and then click on the "titles" or "author" and then search via the page number. It takes way longer to check whether I have already catalogued a book or not. Is this happening to anyone else?

Maio 14, 2:21 am

This is a very old topic.

Maio 16, 8:24 am

>4 SunshineMS: What are some of the failed searches in "Your books" that aren't finding the titles you want? I assume you're searching "All collections" (checking the Collections drop-down menu, on the left of the Top Bar on the page), since you mention being able to sort and browse to find the titles, yes?

I've just cleared your caches and reindexed your catalog, if you want to try some of your previously failed searches again to see if that helped? If not, pass along your searches that are failing and I can take a closer look. Thanks.

Jul 20, 4:55 pm

I know this topic is older, and I'm not sure if someone can help me with this. The "Search My Library" usually works really well with my books' barcodes. However, anything that I added today is not coming up when I search the barcode even though I see the book listed in my library. Even when I try to search by title it doesn't come up. All of the books prior to today come up just fine. Any suggestions? Thanks!

Jul 20, 5:01 pm

>7 MCADirector: Can you give a book example?

Editado: Jul 20, 5:07 pm

Mensagem removida pelo autor.

Jul 20, 5:07 pm

>8 gilroy: Yes! "The Cool Bean" by Jory John 9781338757293

Editado: Jul 20, 6:51 pm

>10 MCADirector: You just added it to your catalog today, it probably hasn't indexed yet which is why search doesn't find it. Other books you added today also fail a search. You can either be patient or reindex your books manually via this link ->

Jul 21, 8:52 am

>7 MCADirector: There's a bug report for this problem here: