Unable to edit a post from last year

DiscussãoBug Collectors

Entre no LibraryThing para poder publicar.

Unable to edit a post from last year

1humouress
Editado: Fev 13, 3:52 am

I’m catching up on old reviews and I’m trying to edit one from October last year

https://www.librarything.com/topic/354049#8260267

but I am unable to open it when I click the ‘edit’ button. This happens both on my desktop and on my iPad using Safari. I can open recent posts (on my thread for this year) when I click the ‘edit’ button. I’ll try other avenues.

iMac Ventura 13.6.3 / Safari
updated: Ventura 13.6.4

iPad Air 4th generation iPadOS 17.2 / Safari

2MarthaJeanne
Fev 13, 3:34 am

I also can't reply to messages in that topic, although I can reply to messages in its previous topic and edit topics of mine from that time.

3humouress
Editado: Fev 13, 3:54 am

>2 MarthaJeanne: Thanks for taking a look. At least it's not (or doesn't seem to be) just me.

I've updated my iMac but still no joy.

4kristilabrie
Fev 13, 7:48 am

My guess is that, because the thread is failing to load fully (thanks to an image at https://www.brainscape.com/blog/wp-content/uploads/2010/09/1600x1309_7011_Mushro..., the actions on the thread are unable to be done.

5humouress
Fev 13, 8:57 am

>4 kristilabrie: Thamks. Please can you tell me which post that’s in and I’ll try to remove it? If I can.

6knerd.knitter
Fev 13, 9:04 am

I actually tested this and the post did eventually load, I was able to click the reply buttons. It just takes a long time for it to load fully.

7norabelle414
Fev 13, 9:46 am

>5 humouress: I believe it's in message #10, next to "Downtime : Skulduggery Pleasant"

8knerd.knitter
Fev 13, 9:49 am

I don't know if it's the bad image that's the problem or just the fact of there being so many images it has to load on that page

9humouress
Fev 13, 9:57 am

>6 knerd.knitter: >7 norabelle414: >8 knerd.knitter: Thanks everyone!

It did take a while to load and I managed to change the image. Now I seem to be able to edit the other post.

>7 norabelle414: >8 knerd.knitter: I think it was that particular image. It doesn't seem to exist anymore on the original site that I got it from.

10humouress
Fev 13, 10:00 am

... or not. Maybe there are other images that I have to wait for to load ...

11kristilabrie
Fev 13, 2:29 pm

The thread loaded fine for me, just now. Maybe was that image?

12AnnieMod
Fev 13, 3:50 pm

>11 kristilabrie: That's a known limitation in Talk - none of the buttons (including edit and delete and the admin actions) work until the page fully loads - so if there was one taking forever, the thread is untouchable until it loads. It is usually very obvious on threads with a lot of images - but it is valid for any thread. :)

It is still loading for me at the moment - so something in there is still slow to load but I expect that when all of these time out or load, it will clear up.

13humouress
Editado: Fev 14, 2:10 am

I managed to edit the post that I wanted having deleted that image after waiting for the thread to load. After that, the thread seemed to work sometimes and not at other times ie load immediately or take a while. I'm assuming it was still settling down?

ETA: I just tried it now (in Safari on my laptop) and I could open the (same) post to edit pretty much straight away.

14timspalding
Fev 14, 7:11 am

Lucy: Can we get CH to move the JS to the top of the page?

T

15conceptDawg
Fev 14, 12:16 pm

We were already doing that.
But I have made a couple of changes which should make long talk threads faster.
One change to our network infrastructure, another to img tags in talk threads.
We'll see if these fix the issue.