Overcat Search Not Working In Add New Books

DiscussãoBug Collectors

Entre no LibraryThing para poder publicar.

Overcat Search Not Working In Add New Books

1GloriaMundi93
Jan 19, 7:57 pm

Overcat does not search when I try to Add New Book. Amazon.com, Library of Congress, seem to work. British Library does not. When I search in Overcat it says "No Results Found For..." I have tried several book titles including very common ones and nothing is being found.

2waltzmn
Jan 19, 8:10 pm

Always, when reporting a bug, please start with:
1. The device you are using (computer, phone, whatever)
2. Operating system version
3. Browser version

Also, in this case, the books would be useful.

That said, I can confirm the problem. It is quite new -- I added a book via overcat less than an hour ago (around midnight GMT), and none of my tests find anything now.

ARM Mac
MacOS 13.6.3
Firefox 121.0.1

Search terms tried:
Claude Simpson
Morgan Ring
Variorum Chaucer
pills to purge melancholy
Beowulf

We should all probably try again in a few hours. Sources DO fail, and it's usually at the other end, not LibraryThing's end.

3GloriaMundi93
Jan 19, 8:55 pm

Thanks for the info, its my first Bug Report.

Dell XPS 13 Plus Laptop
Windows 11
Firefox 121.0.1 64 bit

Towards Democracy
Edward Carpenter
Dracula
Harry Potter

I'll try again in a few hours.

4lilithcat
Editado: Jan 19, 9:49 pm

>3 GloriaMundi93:

Are you searching by title or ISBN?

I just did a search on Overcat by ISBN for The Annotated Dracula and it came right up, though using just the title did not work.

5lesmel
Jan 19, 9:48 pm

British Library isn't going to work for weeks if not months. They were hacked & it's going to take time for them to recover.

7MarthaJeanne
Jan 20, 2:25 am

Noting that OverCat is the one source that LT has control of.

8Nicole_VanK
Jan 20, 3:08 am

>1 GloriaMundi93: If I remember correctly OverCat only works if some other LT member entered the book from a library source before. So if people have entered them manually or from Amazon - no luck

9MarthaJeanne
Jan 20, 3:39 am

This may be a general problem with title searches, as Harry Potter is not working for several sources, both library and Amazon.

10jakebornheimer
Jan 21, 9:05 am

I'm also finding this to be the case (can't find anything through overcat)

1. Desktop computer, custom
2. Win 11
3. Firefox 121.0.1 64 Bit

11MarthaJeanne
Jan 21, 9:44 am

>10 jakebornheimer: What are you searching for? Titles or ISBNs? Please include examples.

12ScarletBea
Editado: Jan 22, 9:41 am

Same here:

1. Laptop
2. Windows 10
3. Chrome version 120.0.6099.71

I searched for, a few examples:
In Memoriam
Black trillium
A day of fallen night

Eventually I added them from Amazon, but I hate doing that...

13lilithcat
Jan 22, 9:46 am

>12 ScarletBea:

How did you search? In Memoriam comes up immediately in Overcat if you use the ISBN. Same with Black Trillium and A Day of Fallen Night.

14MarthaJeanne
Jan 22, 10:07 am

>12 ScarletBea: Yes, Overcat comes up with 7 results using your ISBN for Black Trillium.

There is obviously a bug here about how search is treating titles. Next time, you can try the ISBN rather than turning to Amazon right away.

15waltzmn
Jan 22, 11:00 am

>14 MarthaJeanne: Next time, you can try the ISBN rather than turning to Amazon right away.

Only helpful if a book is new enough to have an ISBN, though. Two of my five sample searches were directed at books that are too old for that. :-/ So it really needs a fix.

16ScarletBea
Editado: Jan 22, 1:19 pm

Yes, I always start searching by ISBN - neither that nor title (second option) was working.

I found In Memoriam by using my ISBN (now), but not A Day of Fallen Night, ISBN 9781526619815.
And The last passenger, ISBN 9781529382822, doesn't appear on overcat - at least just now.

I'm also trying to add Murdle, my ISBN is 9781800818026, and it's not showing up, either searching for the ISBN or the title - which doesn't make sense because I can see the book when I just added the touchstone.

17GloriaMundi93
Jan 22, 1:58 pm

Overcat still not turning up Title and Author search results. Much of my collection is pre ISBN and I have entered items using Overcat before so this is a new bug. Much of what I have is not on Amazon or the particular early edition is not. Author name search is also not working, I tried Stephen King and Thomas Mann.

Dell XPS 13 Plus Laptop
Windows 11
Firefox 121.0.1 64 bit

18nwaspace
Jan 25, 8:11 pm

Overcat is still not giving Title or Author search results. Must of our collection is science volumes that pre-date ISBN. This is a new bug as we have entered several hundred items perviously.

The current item is The Romance of the Heavens, Gerald Beavis, Philadelphia, J. B. Lippincott, 1931.

I am using a 2019 MacBook Pro with a 2.3 GHz 8-core Intel Core i9 using macOS Sonoma 14.2.1 and Safari 17.2.1.

19lilithcat
Editado: Fev 3, 9:48 pm

>18 nwaspace:

You won't get a result from Overcat when no one has catalogued the book from a library source.

20jakebornheimer
Fev 3, 9:12 pm

>11 MarthaJeanne: For example, it returns no results for searches like:

"bible",
"oxford dictionary of english etymology",
"wolf solent, penguin" (whereas the book's ISBN 0140021825 does bring up results)

As another user that values the ability to search for pre-ISBN titles without having to correct horrendously incorrect Amazon metadata, I'm hoping for an update to the situation.

21ShannonEBrown
Fev 4, 4:21 pm

I am experiencing the same issue. No search results coming up at all on Overcat for non ISBN search.

22kristilabrie
Fev 5, 9:29 am

Thanks for the reports, and for your extended patience! Waiting for ccatalfo to get back and I'll see if I can look at this with him. I'll report back.

23kristilabrie
Fev 5, 11:28 am

Okay, seems to be working now - please let me know if you're still seeing issues.

24davidgn
Editado: Fev 5, 8:58 pm

Looks like there is still an issue.
cf. https://www.librarything.com/topic/358071#8403064

To reproduce: search Overcat for "You can die, zanetti" versus "9781420154368"

25GloriaMundi93
Fev 6, 12:40 pm

Dell XPS 13 Plus Laptop
Windows 11
Firefox 121.0.1 64 bit

Overcat seems to be working for me now in both title and author searches. Thanks to whoever fixed it!