Cannot Reorder Collections

DiscussãoBug Collectors

Entre no LibraryThing para poder publicar.

Cannot Reorder Collections

1fuzzi
Jan 2, 1:20 pm

No solution in the previous Bug threads for this issue. (https://www.librarything.com/topic/205134#5341544)

I go to the main header, click on "Your Books", click on Collections, scroll down to Edit Collections.

I was able to create new collections for 2024, but when I try to drag and drop it doesn't allow me to put them where I want them. If it allows me to drag and drop, it drops them to the bottom of the list.

Thanks for any assistance.

2AnnieMod
Editado: Jan 2, 1:29 pm

Browser and OS? Any plugins still enabled?
I just created my new 2024 collection and reordered a few successfully (Firefox on Windows) so it is likely to be browser, OS or security software related...

3fuzzi
Jan 2, 2:27 pm

>2 AnnieMod: I'm on a Dell desktop, Windows 10. I was using Firefox.

I was able to create collections on my iPad, but didn't see any way of reordering them.

4karenb
Editado: Jan 3, 5:56 am

I had trouble doing this earlier today, and it only worked when my catalog was showing All collections.

It probably didn't help that I was trying to move the collection that I had open. However, I was unable to drag-and-drop another collection, too. (I don't know if this is a bug or just how the Collection Manager box works.) (Editing to fix the name of the box.)

5fuzzi
Jan 3, 6:30 am

Update: I got it to work, but nothing has changed as far as browser, OS, etc.

I deleted 4 inactive collections.
I saved it, reopened it to All Collections.
I clicked on Edit.
Same thing happened, collections would drop down when I tried to drag and drop upwards. It did not drop down all the way, but to a point below where it had been before I tried to drag and drop. When I tried it again the collection dropped even farther down the list. I stopped trying.

Then I tried to drag and drop downwards on the list, and it worked.
After I dragged and dropped downwards several of them successfully and tried the drag and drop upwards it worked.

The deletion of a few inactive collections didn't help immediately, not sure if that was the issue.

6kristilabrie
Editado: Jan 3, 10:14 am

>1 fuzzi: >5 fuzzi: You have a lot of Collections, so I'm not surprised. I've seen this happen with long lists of Collections and dragging and dropping. What I've seen help is dragging-and-dropping in spurts, so you're not trying to drag throughout the entire menu at once (which will fail). I'll note this to conceptDawg for when we redo "Your books" (for LT2) but will defer this for now.