Unable to find book by 10-digit LCCN

DiscussãoBug Collectors

Entre no LibraryThing para poder publicar.

Unable to find book by 10-digit LCCN

1gcthomas
Jan 10, 2021, 8:58 pm

I tried to add this book to my library from the Library of Congress: https://lccn.loc.gov/2004047194. I selected the Library of Congress and entered the LCCN, but the search page reported: No results found for "2004047194".

I was able to find the record when searching by ISBN 9781583940938.

2newcrossbooks
Jan 10, 2021, 11:42 pm

>1 gcthomas:
I can confirm that LCCN 2004047194 gives no result when trying to add a book from the LoC.

It's not the way that I usually add books but I use the LoC a lot and so have looked at what happens if I try 'adding' a few books using LCCN from my catalogue.

The following LCCN all found the correct book: 72097666, 99087453, 2004105058, 2008299360, 2001002573, 2011039300, 2012019332, 2013036593, 2013901848, 2014453534, 2015331197, 2016956110, 2017957405, 2017963995, 2018957274, 2019013853, 2019472615, 2020366440, 2020399424

The following LCCN reported no book found: 2016939427 (ISBN 9783319304311). This book was added to my catalogue via the LoC.

I'm not sure what this shows, apart from a 10% failure rate, but I hope it helps someone sort out what's going wrong.

3bnielsen
Jan 11, 2021, 4:05 am

I wonder if the LCCN 2004047194 is in the same field as the ones that succeed?
I tried connecting directly to lx2.loc.gov:210/lcdb with a z39.50 client, and

LCCN 72097666 gives a record with
010 $a 72097666
020 $a 0226345483
035 $9 (DLC) 72097666
040 $a DLC $c DLC $d DLC
...

while 2004047194 gives a record with
010 $a 2004047194
020 $a 1583940936 (pbk.)
040 $a DLC $c DLC $d DLC

but 2017957405 gives a record with
010 $a 2017957405
020 $a 9781487001889
040 $a DLC $b eng $e rda $c DLC
...

so that didn't help us :-)

(I was guessing that maybe LT searched in field 035, thus requiring it to appear like in 72097666. But 2004047194 and 2017957405 both have it only in 010 and 2004047194 can't be found but 2017957405 can.)

So I'm puzzled. We need to summon one of the LT admins.

4gilroy
Jan 11, 2021, 5:52 am

This technically isn't a bug, but I'll let the developers come back and confirm.

We search by title, author, or ISBN. Don't search by LCCN.

5rodneyvc
Jan 11, 2021, 6:38 am

>4 gilroy: Yes, but the explanatory text under the search box includes "LC card number"

6gilroy
Jan 11, 2021, 6:41 am

>5 rodneyvc: Been so long since I added books through the Add Book page, I'd forgotten that.

Maybe it needs to be prefaced?
LCCN:{number} ?

7newcrossbooks
Jan 11, 2021, 7:04 am

>4 gilroy:
It reminds me that there are currently other problems and inconsistencies with LoC searches. Searching the LoC by ISBN can currently give different results to searching by title, as reported in https://www.librarything.com/topic/323055

Books catalogued from LoC when searching by ISBN usually lose any accented characters that are in the data, wheras books catalogued by title don't and, having checked, neither do books catalogued by LCCN. Several examples are noted in the 323055 bug report, here's another example:
ISBN 273849319X
Ethiopie-Erythrée : frères ennemis de la Corne de l'Afrique by Fabienne Le Houérou
LCCN 00398533
(by ISBN gives Ethiopie-Erythr : fres ennemis de la Corne de l'Afrique by Fabienne Le Houou)

But not always. For instance:
ISBN 9781498536417
Inequalities and conflicts in modern and contemporary African history : a comparative perspective by Jan Záhořík
LCCN 2018044013
(gives the author's name correctly when searched by ISBN)

Something's not quite right somewhere...

8jjwilson61
Jan 11, 2021, 12:00 pm

AFAIK LT doesn't perform the search, it just passes on the search string to the library, in this case the LoC. Theoretically every library could have a different format for their search string but luckily it seems that a bare ISBN or Title works in general. But if there's a problem with LoC searches then there might not be anything that LT can do about it.

9Foretopman
Jan 11, 2021, 12:41 pm

Further to >8 jjwilson61: Be aware that the facilities that LT use to search any particular library are not necessarily the facilities that library exposes on its website for general use. So, even if a search you perform at a LoC site using LCCN works, the same search as done by LT could fail, and there still might not be anything LT can do about it.

10bnielsen
Jan 11, 2021, 6:33 pm

>9 Foretopman: Correct. But I used the same access in >3 bnielsen: as LT does, so it should be fixable on the LT side.

11kristilabrie
Jan 12, 2021, 9:58 am

Noted this to developers to take a look. I am seeing the LCCN in the record details on LoC's Add books search result (when searching by ISBN), for what it's worth.

12ccatalfo
Jan 12, 2021, 11:03 am

Hi all - thanks for the heads up and the notes, etc. I will dig in to see what exactly LT is doing in these cases.

13kristilabrie
Out 11, 2022, 9:16 am

14AbigailAdams26
Fev 24, 2023, 1:52 pm

Bumping this, as I have received two additional email reports of difficulty searching via LCCN. In addition, the members report general trouble searching, when using LoC as a source.

15lesmel
Editado: Fev 28, 2023, 3:58 pm

16cairoartsjp
Editado: Mar 1, 2023, 5:58 am

Books with only card number and no ISBN, and books having both, can be found using Overcat. I just discovered this.
I discovered also that if you type the title instead of the card number you`ll get the result.
LCC: Title only works.
Overcat: LCC card number works, and returns LCC result in addition to results from other sources as well.

A thread exists here: https://www.librarything.com/topic/348982

Update: Some LCC card numbers/ISBNs return multiple LCC results for the single same book.

17newcrossbooks
Mar 12, 2023, 1:27 pm

The problems with importing books via LCC seem to be getting worse. None of the LCCN checked to be working in >2 newcrossbooks: now work.

While I managed to import records for a magazine by searching for the title Tenśāʼé today, LT has not managed to find any of the following magazine titles using LCC as a source:
Maʻedot (LCCN - 2007206501)
Malakat (LCCN - sf 93071835)
Ḥamara ṣedeq (LCCN - 2001295603)

And, oddly, the magazine title Yaḥeṡānāt demṡ : yaḥeṡānāt dahnenat ṭebaqānā ṭeqāt takalākāy māh̲bar maṣeḥét = Children's voice : the newsletter of ANPPCAN--Ethiopia (LCCN - 2002375664) is not found when searching for Yaḥeṡānāt, or 2002375664, but is found when searching for Children's voice.

18waltzmn
Mar 12, 2023, 1:53 pm

>17 newcrossbooks: And, oddly, the magazine title Yaḥeṡānāt demṡ : yaḥeṡānāt dahnenat ṭebaqānā ṭeqāt takalākāy māh̲bar maṣeḥét = Children's voice : the newsletter of ANPPCAN--Ethiopia (LCCN - 2002375664) is not found when searching for Yaḥeṡānāt, or 2002375664, but is found when searching for Children's voice.

I don't think this is surprising at all, although it's unfortunate. I can't speak to the LCCN, but "Yaḥeṡānāt" contains four extended-character-set characters. Each of which can be generated in either of two ways: either by using the direct character (ḥ, ṡ, ā) or by using what are called "combining diacriticals" -- or by omitting the diacritical. That's 27 different ways to enter that single word (81 ways, if you count the two instances of ā as independent), and no way of knowing which might be in the database. :-(

Looking up "Children's voice," it appears that the item that turned up uses the same extended characters as you did, but there are a lot of letters in the other words that might not be the same. In my experience, searching on extended-character-set letters is always chancy, and the more unusual the language, the chancier it is. "Children's voice" probably worked because it has no extended-character-set characters.

I have no advice on the LCCN, but if you conduct a regular search and it doesn't work, it's always a good idea to try a search for only those words without diacriticals.

19newcrossbooks
Mar 12, 2023, 2:20 pm

>18 waltzmn: Thanks, and that's one of the reasons I also searched for "Children's Voice". But the LT search doesn't even find "dahnenat" from the title, which has no extended set characters.
Similarly the title "Malakat" has no extended set characters.
And for a title like "Maʻedot" a search for "Maedot" used to work...

20gilroy
Mar 12, 2023, 7:20 pm

>17 newcrossbooks: The problems with importing books via LCC seem to be getting worse
Considering it was never marked as fixed, it's still in the same state it's always been -- broken. Yes, admin have noted it needs work, but they haven't noted a fix.

21InfoChallenges
Editado: Maio 12, 2023, 6:02 pm

Any suggestions for retrieving LC call numbers using a citation matcher outside LT? Like, first author, year, title, that could fuzzy-match on LC collection records and return the call number?

22lesmel
Maio 14, 2023, 7:45 am

>21 InfoChallenges: It's not a citation matcher; but this does pretty much what you want: http://classify.oclc.org/classify2/ -- search a title (there's more than one search, actually), you get a results list (if there's a single hit you skip to the exact record page), click a result, you get the most frequent LCC and/or DDC, as well as all the call numbers used in the OCLC system.

23AikiBib
Maio 15, 2023, 7:40 am

Cool, thanks!

24kristilabrie
Jan 2, 9:43 am

Potentially related: a book cannot be found by title, title/author, ISBN, LCCN, etc... but can be found by searching the author's name only. https://www.librarything.com/topic/356182

25nandm
Jan 9, 2:21 am

As a brand new user, this was the first thing I encountered when trying to add my first book via Library of Congress catalog card number. I grabbed the closest book to me and tried that. Printed as 59-13994, I could only get it to return from the LoC's own site by formatting as 59013994 (permalink: https://lccn.loc.gov/59013994). Under no circumstance could I get a result searching from Library of Congress via "Add books" (https://www.librarything.com/addbooks). We have a lot of pre-ISBN books, and the idea of searching by author/title for a work that's already been catalogued with a unique identifier -- and for which explicit guidance seems to exist (ex. https://www.loc.gov/marc/lccn.html, https://www.loc.gov/marc/lccn_structure.html) -- is not inspiring. Could I volunteer my time to help fix this?

26kristilabrie
Jan 9, 7:59 am

>25 nandm: You might be able to get many LoC records by searching the LCCN within the Overcat source, instead (it's our database of hundreds of libraries including LoC). I was able to find the record you need by searching Overcat for 59013994, at least, and there's a lot of cached results that should help move the needle for you. Hopefully we'll be able to dedicate some serious bug-cleanup time within the next few months!

27lesmel
Jan 22, 1:45 pm